Kaynak ikonu

Excelde EĞERSAY - SATIRSAY Formülleri ve Kullanımı

Bir excel sayfasında sütun veya satırlardaki hücrelere girilen verileri türlerine göre saydırmak, gruplamak isteyebilir ve uzun tablolardan gerekli verileri rahatlıkla çakebiliriz.
Not: Microsoft Excel, bir koşula bağlı olan verilerinizi çözümlemek için kullanılabilecek ek fonksiyonları sağlar.
Belirli bir aralıktaki metin dizesini veya sayıyı esas alan bir toplamı hesaplamak için ETOPLA çalışma sayfası fonksiyonunu kullanın.
Belli bir satış miktarına göre satış primi verme gibi, bir koşula göre iki değerden birini veren bir formül oluşturmak için EĞER çalışma sayfası işlevini kullanın.
Boş olan veya boş olmayan hücreleri saymak için BAĞ_DEĞ_DOLU_SAY ve BOŞLUKSAY fonksiyonlarını kullanın.
Şimdi EĞERSAY ve SATIRSAY formüllerinin kullanımı ile ilgili örneklere geçelim. Örnek formülleri daha da geliştirerek kullanabilirsiniz.

D3iswho.png

Yukarıdaki resme göre A2 - A11 hücreleri arasındaki 10 satırlık sütundaki verilerle çalışma yapıyoruz.

1. Formülümüz alttaki gibi olacak. Böylelikle A2:A11 hücreleri arasında metin girilmiş hücrelerin sayısını alıyoruz. Üstteki resimde görüldüğü gibi 6 adet hücreye metin girmişiz. (Rakam girilen hücreleri saymaz)
Kod:
=EĞERSAY(A2:A11;"*")
2. Formül alttaki şekilde. Bu formülle aralıktaki satırları sayıyoruz.
Kod:
=SATIRSAY(A2:B11)
3. Formül alttaki şekilde. Böylelikle ilk önce satırların sayısını buluyoruz sonra metin girilmiş hücreleri sayarak farkını alılyoruz. Sonuçta boş satır sayısnını alıyoruz.

Bu şekilde örneğin; bir sınıf listesinde sınava girmeyen öğrenci sayısını tespit edebiliriz.
Kod:
=SATIRSAY(A2:B11)-EĞERSAY(A2:A11;"*")
4. Formül alttaki şekilde. Bu şekilde uzun bir sütunda bulunan herhangi bir kelime sayısını alabiliriz. Örneğin kız öğrencilerin sayısı gibi.
Kod:
=EĞERSAY(A2:A11;"=elma")
5. Formül alttaki şekilde. Yuakrdaki formüle bir ek yaptık sadece. AElmalarla birlikte Armutların sayısını da aldık. Bu şekilde eklemerer yapabilirsiniz.
Kod:
=EĞERSAY(A2:A11;"elma")+EĞERSAY(A2:A11;"armut")
Gönderen
YoRuMSuZ
Gösterim
667
İlk yayınlama
Son güncelleme
Değerlendirme
0.00 star(s) 0 oy

YoRuMSuZ: diğer kaynakları

Top