Kaynak ikonu

Excelde Satır Renklendirme -

İndirmek için giriş yapınız

YoRuMSuZ

Biz işimize bakalım...
Excelde Satır Renklendirme - Excelde Satır Renklendirme

Uzun Excel dosyaları ile çalışırken satırların birbirinden daha net şekilde ayrılması için satırların uygun renk tonlarında renklendirilmesi oldukça göze hoş gelen görünüm oluşturuyor. Ancak manuel olarak renklendirdiğiniz satırlar A-Z veya Z-A sıralaması yaptığınızda bozulup birbirine geçiyor.] İşte bu durumda yine bizim imdadımıza excel'in "Koşullu Biçimlendirme" fonksiyonu imdadımıza yetişiyor. Örneğimizde bu sorunu bertaraf edeceğiz.

Zip...

Açıklamanın devamı için tıklayınız...
 
Son düzenleme:

YoRuMSuZ

Biz işimize bakalım...
Bu konuya ek yapıyorum...

Yukarıdaki konuda A sütununa veri girildiğinde (yani gerektiğinde) satırlar otomatik olarak renkleniyor. Eğer excel dosyanızın belirlediğiniz alanında satırların veri girilmeden (boşken) renklendirilmesini isterseniz formülü alttaki şekilde kullanmalısınız...

Kod:
=EĞER(MOD(SATIR(A1);2)=0;1;0)

Formülü, Excel tablomuzun herhangi bir alanında sadece başlangıç hücresini değiştirerek kullanabilirsiniz.
 

artiztttt

Üyecik
Selam Merhaba;

bir iş dosyası içerisinde aynı şekilde yenilenen 3 lü 4 lü isimler değerler bulunmakta isimler bu konuda yenilenen değerlerin renklendirebilmek için hangi formül veya kural kullanılmalıdır örnek vereyim

ahmet sağlam
mehmet
hasan
ahmet sağlam
ali
veli
ahmet sağlam
.
.
.
bu şekilde uzayan listede bu aynı isimde olan kişileri nasıl belirtebilirim. yardımlarınızı bekliyorum belki burası yeri değildir şimdiden teşekkürler
 
Selam Merhaba;

bir iş dosyası içerisinde aynı şekilde yenilenen 3 lü 4 lü isimler değerler bulunmakta isimler bu konuda yenilenen değerlerin renklendirebilmek için hangi formül veya kural kullanılmalıdır örnek vereyim

ahmet sağlam
mehmet
hasan
ahmet sağlam
ali
veli
ahmet sağlam
.
.
.
bu şekilde uzayan listede bu aynı isimde olan kişileri nasıl belirtebilirim. yardımlarınızı bekliyorum belki burası yeri değildir şimdiden teşekkürler

sanırsam istediğiniz şu :)
 

YoRuMSuZ

Biz işimize bakalım...
Koşullu biçimlendirme ile olabilir ancak isimler arttıkça (koşul verme sınırlıdır) sorun yaşarsınız. Makro ile yapabilirsiniz. Yukarıdaki örneği de (judgeofnight'ın verdiği link) incelemeniz yararınıza olacaktır.
 

SERTTAŞ

Üyecik
Excell 2003 kullanıyorum.. Bir dosyada t.c kimlik no,ad soyad vs gibi bilgiler var. T.c kimlik noya göre çift kayıtları bulup,çift kayıt bulunan satırı-ları komple renklendirmek istiyorum bunu nasıl yapabilirim. (koşullu biçimlendirme formülü gibi) şimdiden tşekkürler
 

YoRuMSuZ

Biz işimize bakalım...
Verilerin A1 ve A10 sütun aralığında olduğunu varsayalım.

Bu aralıktaki aynı kayıtları renklendirmek için Koşullu Biçimlendirme ve EĞERSAY fonksiyonlarını kullanalım.

* Bu aralığı seçili hale getirin.
* Biçim > Koşullu Biçimlendirme iletişim kutusunu açın.
* Formül seçeneğini aktif edin.
* Şu formülü girin.
Kod:
=EĞERSAY(A:A;A1)>1
* Pencereyi kapatmadan Biçim menüsünden istediğiniz biçimlendirmeyi yapın.

Artık mükerrer kayıtlar biçimlendirdiğiniz şekilde renklenir.
 
Bu konuya ek yapıyorum...

Yukarıdaki konuda A sütununa veri girildiğinde (yani gerektiğinde) satırlar otomatik olarak renkleniyor. Eğer excel dosyanızın belirlediğiniz alanında satırların veri girilmeden (boşken) renklendirilmesini isterseniz formülü alttaki şekilde kullanmalısınız...

Kod:
=EĞER(MOD(SATIR(A1);2)=0;1;0)

Formülü, Excel tablomuzun herhangi bir alanında sadece başlangıç hücresini değiştirerek kullanabilirsiniz.
Teşekkür ederim çok işime yaradı...
 
Top