Excelde EĞERSAY - SATIRSAY Formülleri ve Kullanımı

Konusu 'Excel Çalışmaları' forumundadır ve YoRuMSuZ tarafından 1 Aralık 2007 başlatılmıştır.

  1. YoRuMSuZ

    YoRuMSuZ Biz işimize bakalım!

    Katılım:
    7 Haziran 2006
    Mesajlar:
    20.517
    Beğenileri:
    1.002
    Ödül Puanları:
    7.080
    Cinsiyet:
    Bay
    Bir excel sayfasında sütun veya satırlardaki hücrelere girilen verileri türlerine göre saydırmak, gruplamak isteyebilir ve uzun tablolardan gerekli verileri rahatlıkla çakebiliriz.
    Not: Microsoft Excel, bir koşula bağlı olan verilerinizi çözümlemek için kullanılabilecek ek fonksiyonları sağlar.
    Belirli bir aralıktaki metin dizesini veya sayıyı esas alan bir toplamı hesaplamak için ETOPLA çalışma sayfası fonksiyonunu kullanın.
    Belli bir satış miktarına göre satış primi verme gibi, bir koşula göre iki değerden birini veren bir formül oluşturmak için EĞER çalışma sayfası işlevini kullanın.
    Boş olan veya boş olmayan hücreleri saymak için BAĞ_DEĞ_DOLU_SAY ve BOŞLUKSAY fonksiyonlarını kullanın.
    Şimdi EĞERSAY ve SATIRSAY formüllerinin kullanımı ile ilgili örneklere geçelim. Örnek formülleri daha da geliştirerek kullanabilirsiniz.

    [​IMG]

    Yukarıdaki resme göre A2 - A11 hücreleri arasındaki 10 satırlık sütundaki verilerle çalışma yapıyoruz.

    1. Formülümüz alttaki gibi olacak. Böylelikle A2:A11 hücreleri arasında metin girilmiş hücrelerin sayısını alıyoruz. Üstteki resimde görüldüğü gibi 6 adet hücreye metin girmişiz. (Rakam girilen hücreleri saymaz)
    Kod:
    =EĞERSAY(A2:A11;"*")
    2. Formül alttaki şekilde. Bu formülle aralıktaki satırları sayıyoruz.
    Kod:
    =SATIRSAY(A2:B11)
    3. Formül alttaki şekilde. Böylelikle ilk önce satırların sayısını buluyoruz sonra metin girilmiş hücreleri sayarak farkını alılyoruz. Sonuçta boş satır sayısnını alıyoruz.

    Bu şekilde örneğin; bir sınıf listesinde sınava girmeyen öğrenci sayısını tespit edebiliriz.
    Kod:
    =SATIRSAY(A2:B11)-EĞERSAY(A2:A11;"*")
    4. Formül alttaki şekilde. Bu şekilde uzun bir sütunda bulunan herhangi bir kelime sayısını alabiliriz. Örneğin kız öğrencilerin sayısı gibi.
    Kod:
    =EĞERSAY(A2:A11;"=elma")
    5. Formül alttaki şekilde. Yuakrdaki formüle bir ek yaptık sadece. AElmalarla birlikte Armutların sayısını da aldık. Bu şekilde eklemerer yapabilirsiniz.
    Kod:
    =EĞERSAY(A2:A11;"elma")+EĞERSAY(A2:A11;"armut")
  2. dilek555

    dilek555 Üye

    Katılım:
    10 Şubat 2008
    Mesajlar:
    2
    Beğenileri:
    0
    Ödül Puanları:
    20
    Ben yeni üyeyim. Excelde sadece basit formüller oluşturuyorum. Benim işim için bir formüle ihtiyacım var yardımcı olursanız sevinirim.

    Ben excelde uzun bir tablo hazırlıyorum. A sütunuda fatura kesilen isimler var, B sütununda fatura bedeli var.Örneğin 2. satır ile 310. satır arasında diyelim.

    İSTENEN: Her isim için kesilen fatura adedi(toplamı sadece 8.000i geçenler lazım) ve bunların toplam tutarları lazım.

    Ve çok fazla isim var ve ben bu isimleri tek tek girmeden sonuç alabilmeliyim.

    Çok uğraştım çok denedim ama yapamadım. Yardımcı olursanız sevinirim.
  3. sherry

    sherry V.I.P Vip Üye

    Katılım:
    20 Aralık 2006
    Mesajlar:
    2.244
    Beğenileri:
    15
    Ödül Puanları:
    1.880
    Ne isteğinizi tam olarak anlamadım ama anladıklarım doğrultusunda işinize yarayabilecek formülleri ekledim. Umarım işinize yarar.

    2.satır ile 310. satır arasında kesilmiş olan fatura sayısını bulmak için dolu olan hücre sayısını bulmamız lazım bunun içinde 311. satıra şöyle bir formül yazabiliriz.
    Kod:
    =SATIRSAY(A2:A310)-EĞERSAY(A2:A310;"")
    yada

    Kod:
    EĞERSAY(A2:A310;"<>""")
    formüllerinden birini kullanabilirsiniz.

    8000'den büyük olanların sayısını bulmak için

    Kod:
    EĞERSAY(A2:A310;">8000")
    formülünü kullanabilirsiniz.

    8000'den büyük olanların toplamını bulmak için de

    Kod:
    =ETOPLA(A2:A310;">8000")
    formülünü kullanabilirsiniz.
  4. dilek555

    dilek555 Üye

    Katılım:
    10 Şubat 2008
    Mesajlar:
    2
    Beğenileri:
    0
    Ödül Puanları:
    20
    Öncelikle ilginize teşekkürler.

    A B
    İSİMLER FAT.TUTARI
    1 Ahmet 2000
    2 Ayşe 4000
    3 Ali 3000
    4 Ahmet 7000
    5 Elif 2000
    6 Ayşe 4000
    7 Dilek 9000

    Ben aslında tek bir sonuç istemiyorum.
    Sonuç:Ahmet 2 fat. toplam 9000
    Ayşe 2 fat. toplam 8000
    Dilek 1 fat. toplam 9000 olmalı.

    Sadece toplam kesilen tutar 8000i aşanlar lazım. Ama hangi isime kaç fatura kesilmiş toplam tutar ne? Bunu bulabilir miyim formülle?
    Tekrar teşekkürler..
  5. yuksel03

    yuksel03 Üye

    Katılım:
    26 Ocak 2008
    Mesajlar:
    3
    Beğenileri:
    0
    Ödül Puanları:
    20
    Baba bunlar harika ya.Çok teşekkürler.Devamını bekleriz.

Sayfayı Paylaş

Konu Etiketleri...

  1. 10 sınıf ofis toplam eğer say formüller